Service Lewes seems to be down

Major incident Lewes
2020-10-28 12:09 GMT · 12 minutes

Updates

Issue

All services are fully operational with the team continuing to monitor application activity

November 4, 2021 · 15:24 GMT
Resolved

Service is back up.

October 28, 2020 · 12:22 GMT

← Back